Actions

Verifying lawful interception

Revision as of 19:18, 10 December 2020 by Allyntree (talk | contribs) (→‎TMG7800 system)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)


This article applies to: Product Version
Tmedia 2.7, 2.8, 2.9, 2.10, 3.0, 3.2
SBC 3.0, 3.1

Installing ruby 'gem'

The Lawful Intercept filter script requires the 'json' ruby gem.

TMedia units (TMG800, TMG3200, TMG7800), provided by TelcoBridges, are now shipped with this 'gem' installed.

If you have older TMedia units, or if you are using your own host, verify that the host has the 'json' gem installed:

 gem list --local

Output example:

 *** LOCAL GEMS ***
 
 bundler (1.2.3)
 fcgi (0.8.7)
 json (1.7.7)    <---- json installed


If it is missing, it can be installed from a shell:

 gem install json

Allowing SFTP password-less connection

If your IRI server uses SFTP, TelcoBridges system must be enabled for password-less connections.

IMPORTANT: The password-less SSH procedure must be executed on all units in a redundant Tmedia system:

TMG3200 1+1 or TMG800 1+1 system

The password-less procedure must be executed on both units

TMG7800 system

The password-less procedure must be executed on both TMG7800-CTRL units.