Actions

Security Policy


The TelcoBridges Tctrl Operating Software runs over a variant of CentOS 5 or 7 that is managed by TelcoBridges. The resulting operating system is a selected set of binary packages (RPM) meticulously chosen from RedHat/CentOS official packages. Some software packages version have been frozen on earlier release to ensure a full compatibility and quality of TelcoBridges software. As an example, the Ruby version package that TelcoBridges uses (1.8.7) follows CentOS 6 repository, since CentOS 7 integrates version 2.x. TelcoBridges follows RedHat/CentOS, and vendors security announcement by subscribing to their mailing list.

Security Update Procedure

When a new security update (RHSA) is released from RedHat or from the vendors of one of the software component not following the official CentOS package, TelcoBridges follows a rigorous security update procedure:

  1. first check if the affected packages are in one of our repositories.
  2. insert affected package in TelcoBridges DEV repository
  3. after 1 to 1.5 week of development testing, insert the package in the QA repository for regression testing
  4. once tested, migrate the packages from the QA repository to the OFFICIAL repository


TelcoBridges CentOS 5 and 7 Repositories

http://repo.telcobridges.com

Version DEV QA OFFICIAL
CentOS 5 link here link here link here
CentOS 7 link here link here link here


TelcoBridges product upgrade procedure

To upgrade the CentOS packages on one of TelcoBridges products, please follow this link.